自己写的自动翻页浏览工具

我的小作品 CN-P5 1414℃ 0评论

前一阵电脑爱好者上的问题,就是“徘徊”,可以在看漫画类网站实现自动翻页。我写的类似徘徊功能可以比他强,“美景”自动翻页浏览工具

大家测试后给个建议可以留言或消息。代码写的比较乱,因为易语言俱乐部论坛上一个网友说要实现窗口最小化和最大化或者窗口变化是保持控件不变位置的问题,有人发了个模块,但是我用了一下不好用就简单的用代码是现了,提供一个思路。

以下为代码:原创,转载请注明。软件下载使用请看下面。

源程序在winXPSP2+易语言4.5下编译成功。

.版本 2
.支持库 HtmlView

.程序集 窗口程序集2
.程序集变量 文件号
.程序集变量 配置名
.程序集变量 主页

.子程序 重画窗口

窗口高 = 取用户区高度 ()
窗口宽 = 取用户区宽度 ()
地址栏.左边 = 38
地址栏.顶边 = 8
地址栏.宽度 = 窗口宽 - 460
开始.左边 = 地址栏.宽度 + 地址栏.左边 + 4
开始.顶边 = 8
后.左边 = 开始.左边 + 开始.宽度 + 2
后.顶边 = 8
前.左边 = 后.左边 + 前.宽度 + 2
前.顶边 = 8
标签4.左边 = 前.左边 + 后.宽度 + 2
标签4.顶边 = 9
秒1.左边 = 标签4.左边 + 12
秒1.顶边 = 10
页1.左边 = 标签4.左边 + 50
页1.顶边 = 10
标签1.顶边 = 11
标签1.左边 = 2
标签2.左边 = 0
标签2.高度 = 20
标签3.高度 = 20
标签3.宽度 = 170
自动.左边 = 前.左边 + 前.宽度 + 2 + 标签4.宽度
设置.左边 = 自动.左边 + 自动.宽度 + 2
浏览框.顶边 = 40
浏览框.左边 = 0
浏览框.宽度 = 窗口宽
浏览框.高度 = 窗口高 - 60
浏览定位 = 浏览框.顶边 + 浏览框.高度
标签2.顶边 = 浏览定位
标签3.顶边 = 浏览定位
标签2.宽度 = 窗口宽 - 170
标签3.左边 = 标签2.宽度
置托盘图标 (#托盘, “美景浏览工具”)

.子程序 __启动窗口_创建完毕

重画窗口 ()
自动.正常图片 = #自动开
自动.点燃图片 = #自动开点
自动.按下图片 = #自动开点
浏览框.地址 = 地址栏.内容
秒1.内容 = “4”
页1.内容 = “1”
秒 = 取绝对值 (到数值 (秒1.内容))
页 = 取绝对值 (到数值 (页1.内容))
文件.可视 = 假
置托盘图标 (#托盘, “美景浏览工具”)

.子程序 _开始_鼠标左键被放开, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

.如果 (地址栏.内容 = “”)
     信息框 (“没有输入网址!”, #确认钮 + #警告图标, “美景 提示”)
.否则
     浏览框.地址 = 地址栏.内容
     标签2.标题 = “正在打开” + 地址栏.内容
.如果结束

.子程序 _浏览框_载入完毕

地址栏.内容 = 浏览框.地址
标签2.标题 = “已打开” + 地址栏.内容

.子程序 __启动窗口_位置被改变

重画窗口 ()

.子程序 __启动窗口_尺寸被改变

重画窗口 ()

.子程序 _设置_被单击

信息框 (“功能正在开发中!”, #确认钮 + #警告图标, “美景 提示”)

.子程序 _检测选择_周期事件

.如果 (地址栏.被选择字符数 ≠ 0)
     选中文本 = 到数值 (地址栏.被选择文本)
     a = 寻找文本 (地址栏.内容, 地址栏.被选择文本, , 假)
     b = 取文本右边 (地址栏.内容, 取文本长度 (地址栏.内容) - a - 1)
     c = 取文本左边 (地址栏.内容, 取文本长度 (地址栏.内容) - a - 地址栏.被选择字符数)
     d = 到文本 (到数值 (地址栏.被选择文本) + 页)
     地址栏.被选择文本 = d
     浏览框.地址 = b + c + d
.否则
     信息框 (“选中的不是数字,请重选!”, #警告图标 + #确认钮, “美景 提示”)
.如果结束

.子程序 _前_被单击

.如果 (地址栏.被选择字符数 ≠ 0)
     选中文本 = 到数值 (地址栏.被选择文本)
     a = 寻找文本 (地址栏.内容, 地址栏.被选择文本, , 假)
     b = 取文本右边 (地址栏.内容, 取文本长度 (地址栏.内容) - a - 1)
     c = 取文本左边 (地址栏.内容, 取文本长度 (地址栏.内容) - a - 地址栏.被选择字符数)
     d = 到文本 (到数值 (地址栏.被选择文本) + 1)
     地址栏.被选择文本 = d
     浏览框.地址 = b + c + d
.否则
     信息框 (“选中的不是数字,请重选!”, #警告图标 + #确认钮, “美景 提示”)

.如果结束

.子程序 _后_被单击

.如果 (地址栏.被选择字符数 ≠ 0)
     选中文本 = 到数值 (地址栏.被选择文本)
     a = 寻找文本 (地址栏.内容, 地址栏.被选择文本, , 假)
     b = 取文本右边 (地址栏.内容, 取文本长度 (地址栏.内容) - a - 1)
     c = 取文本左边 (地址栏.内容, 取文本长度 (地址栏.内容) - a - 地址栏.被选择字符数)
     d = 到文本 (到数值 (地址栏.被选择文本) - 1)
     地址栏.被选择文本 = d
     浏览框.地址 = b + d + c
.否则
     信息框 (“选中的不是数字,请重选!”, #警告图标 + #确认钮, “美景 提示”)

.如果结束

.子程序 _自动_被单击

时钟.时钟周期 = 秒
.如果 (时钟.时钟周期 = 0)
     自动.正常图片 = #自动开
     自动.点燃图片 = #自动开点
     自动.按下图片 = #自动开点
.否则
     自动.正常图片 = #自动关
     自动.点燃图片 = #自动关点
     自动.按下图片 = #自动关点

.如果结束
_检测选择_周期事件 ()

.子程序 _显示_被选择

_启动窗口.可视 = 真
_启动窗口.总在最前 = 真

.子程序 _隐藏_被选择

_启动窗口.可视 = 假

.子程序 _退出_被选择

销毁 ()

.子程序 __启动窗口_托盘事件
.参数 操作类型, 整数型

弹出托盘菜单 (文件)
—————————————————————————————————————————-

美景自动翻页浏览工具(测试版)
    这是我刚写一个小东西,(*^__^*) 嘻嘻……写的不好,大家见谅!
    首先输入网址,选择你要行业的数值比如:

http://hi.baidu.com/1m3fd这个网址你想这样看,下一页是http://hi.baidu.com/1m4fd你可以选中3然后点击上下或者自动翻页按钮。如果下一页是http://hi.baidu.com/1m5fd你可以选中3然后在页前面的框里输入2,则页面地址每

转载请注明:黑白的自留地 » 自己写的自动翻页浏览工具

喜欢 (0)
发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(1)个小伙伴在吐槽
  1. 是不是俺真的太笨了~
    dddylg2007-10-15 14:09 回复