调用系统 开始菜单 运行 对话框

我的小作品 CN-P5 1137℃ 0评论

调用系统 开始菜单 运行 对话框 用了一个系统API 下面是易语言代码

DLL声明:

.版本 2

.DLL命令 SHRunDialog, 整数型, "shell32", "#61", 公开, 显示运行对话框
    .参数 父句柄, 整数型
    .参数 图标句柄, 整数型
    .参数 Unknown2, 整数型, , 0
    .参数 标题, 字节集
    .参数 提示, 字节集
    .参数 uFlags, 整数型

代码:

 

.版本 2

.子程序 _按钮运行_被单击
.局部变量 标题, 字节集
.局部变量 提示, 字节集

标题 = 转换ASCII转Unicode (标题编辑框.内容)
提示 = 转换ASCII转Unicode (提示编辑框.内容)
SHRunDialog (_启动窗口.取窗口句柄 (), 0, 0, 标题, 提示, 位或 (1, 2, 4, 8, 3))
‘ 父窗口句柄 图标句柄 0 标题 提示(U码) 标识号

 

转换ASCII转Unicode 这个编码转换放到下一个“技巧”里面了总结全部常用的A U UTF-8之间的转换。

转载请注明:黑白的自留地 » 调用系统 开始菜单 运行 对话框

喜欢 (0)
发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
(1)个小伙伴在吐槽
  1. 哎 想了一下 自己没有多少时间...所以大家不要追着我问代码什么时候出了...我可以和你交流 大家互相学习一些知识 解决一些问题 也可以在自己力所能及的范围内帮大家写点代码 但是我也要糊口要工作 希望大家理解 可能这算是牢骚 哎 感觉自己很悲哀... 不过我还是会一直关注这里的...有问题可以发到这里 有人看了可以一起交流解决
    rzsky2011-07-01 01:42 回复